NRE Labs Community

Need help with utility-vm image (for Docker lesson)

Hello Everyone,

Need help with Running Docker containers Lesson- I see there is an Issue (#131) opened for the same New Lesson: Docker Containers #131

As suggested in this , I am trying to use utility-vm image which has docker installed.

Few issues that I have with this image -

  1. Every time I get this error message (sudo: unable to resolve host utility-vm)
  2. Looks like no internet connectivity to this container, not able to fetch images from Docker Registry (tried hello-world).

  1. Every time I get this error message (sudo: unable to resolve host utility-vm) —— resolved after adding an entry in /etc/hosts for utility-vm

Q.How to make this happen at lesson launch itself ?

@Pradeep Internet access is disabled for security reasons. The lesson must be self-contained.

For this lesson, there are a few directions you could go

  1. One option might be to place the images in a tarball and place them in the lesson directory, provided they’re not that large. You could then just add a step to install these images in your lesson guide, or even do this automatically once is finished, which will let you automate any endpoint’s configuration.

  2. Alternatively, you could build your own docker image (and contribute all files in your PR) that runs a docker registry of some kind (e.g. quay) with your images preloaded and run your own registry within the lesson environment itself. You’d have to configure the endpoint running the images to use the new registry, which you can again do manually in the lesson guide or automate once the endpoint configuration re-vamp is done.

Hopefully that makes sense.

Hi Matt, @mierdin , thanks for the quick reply. I am trying to use option 1. From inside the container, I am not able to see any lesson files . There is a mount for /antidote but its showing empty. Could you please help fixing this so that we could use the manual docker image files from the lesson folder.

Here is a comparison from Linux Lession (utility image) and new lesson using utility-vm image.

With utility :

With utility-vm :

The intention is to pass the /antidote directory from the outer container “shell” into the VM running ubuntu. I took a stab at this in and AFAIR it worked when I tested it, but it was a while ago.

I will try to get to this at some point, but you should feel welcome to experiment with this yourself, and include any improvements in your contribution.

Checking in - any progress on this?

Hi Matt,

Apologies for the delay in my response (was away on PTO). Didn’t get a chance to test this recently, will update shortly .